March 7, 2019 2:30 PM
Center for Information Technology

A serious security flaw in Google Chrome is under active attack by cybercriminals. Google has already released a patch that should fix the problem and for the most part, Chrome updates are automatic. Because of the severity of the security vulnerability, however, it’s important that you double-check that you’re running the newest version (72.0.3626.121).

To launch Chrome’s update tool, open the browser and select “About Google Chrome,” which you’ll find in the Help section within its primary drop-down menu. Your browser should then automatically update for you if there’s a more recent version to download.

Need help applying the update? Submit a ticket with the CIT Help Desk at support.oberlin.edu or give us a call at (440) 775-8197.